Après avoir installé la dernière version d’Eclipse j’ai eu droit à un plantage juste après l’affichage de la fenêtre d’attente.

La raison de ce plantage est que LUNA cible par défaut la version 3 de la librairie graphique GTK.

Or, pour pouvoir fonctionner sous GTK 3, LUNA a besoin de la version 2.14 de glibc que Wheezy ne propose pour l’instant qu’en version 2.13.

Pour résoudre ce problème, il suffit de forcer Eclipse à utiliser GTK 2 en ajoutant les deux lignes suivantes à votre fichier eclipse.ini.

--launcher.GTK_version 2

Une fois cette modification effectuée, vous pourrez profiter pleinement de votre IDE favori en attendant que la version 2.14 de glibc soit disponible sous Wheezy.

Source : Bug 430736 – Crash at Eclipse startup under Debian Wheezy stable